<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:x="urn:schemas-microsoft-com:office:excel" xmlns:dt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta name="Microsoft Theme 2.00" content="Clear Day 011"><meta http-equiv=Content-Type content="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal>Hmm,<o:p></o:p></p><p class=MsoNormal>Now when I tried to run Leksah, I get not only some broken packages (which I can avoid for my current project), but:<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>&lt;command line&gt;: cannot satisfy -package-id base-4.5.1.0-7c83b96f47f23db63c42a56351dcb917: <o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp;&nbsp;base-4.5.1.0-7c83b96f47f23db63c42a56351dcb917 is unusable due to missing or recursive dependencies:<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; integer-gmp-0.4.0.0-c15e185526893c3119f809251aac8c5b<o:p></o:p></p><p class=MsoNormal>&nbsp; &nbsp;&nbsp;(use -v for more information)<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>So I tried to install base, then re-install it, but both fail;<o:p></o:p></p><p class=MsoNormal>Any hints?<o:p></o:p></p><p class=MsoNormal>&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;&#8211;-<o:p></o:p></p><p class=MsoNormal>C:\Users\guthrie&gt;cabal install base<o:p></o:p></p><p class=MsoNormal>Resolving dependencies...<o:p></o:p></p><p class=MsoNormal>All the requested packages are already installed:<o:p></o:p></p><p class=MsoNormal>base-4.5.1.0<o:p></o:p></p><p class=MsoNormal>Use --reinstall if you want to reinstall anyway.<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>C:\Users\guthrie&gt;cabal install --reinstall base<o:p></o:p></p><p class=MsoNormal>Resolving dependencies...<o:p></o:p></p><p class=MsoNormal>cabal: Could not resolve dependencies:<o:p></o:p></p><p class=MsoNormal>next goal: base (user goal)<o:p></o:p></p><p class=MsoNormal>rejecting: base-3.0.3.2 (conflict: base =&gt; base&gt;=4.0 &amp;&amp; &lt;4.3)<o:p></o:p></p><p class=MsoNormal>rejecting: base-3.0.3.1 (conflict: base =&gt; base&gt;=4.0 &amp;&amp; &lt;4.2)<o:p></o:p></p><p class=MsoNormal>rejecting: base-4.6.0.0, 4.5.1.0, 4.5.0.0, 4.4.1.0, 4.4.0.0, 4.3.1.0, 4.3.0.0,<o:p></o:p></p><p class=MsoNormal>4.2.0.2, 4.2.0.1, 4.2.0.0, 4.1.0.0, 4.0.0.0 (only already installed instances can be used)<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>C:\Users\guthrie&gt;ghc-pkg list base<o:p></o:p></p><p class=MsoNormal>WARNING: there are broken packages.&nbsp; Run 'ghc-pkg check' for more details.<o:p></o:p></p><p class=MsoNormal>e:/Plang/Haskell Platform\lib\package.conf.d:<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; base-4.3.1.0<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; base-4.5.0.0<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; base-4.5.1.0<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>The following packages are broken, either because they have a problem<o:p></o:p></p><p class=MsoNormal>listed above, or because they depend on a broken package.<o:p></o:p></p><p class=MsoNormal>HTTP-4000.2.3<o:p></o:p></p><p class=MsoNormal>haskell-platform-2012.2.0.0<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal>Can I just unregister the old Haskell platform, I now use a newer one?<o:p></o:p></p><p class=MsoNormal>Ghc-pkg list : &#8230;<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; {haskell-platform-2012.2.0.0}<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; haskell-platform-2012.4.0.0<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; haskell-src-1.0.1.4<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; haskell-src-1.0.1.4<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; haskell-src-1.0.1.5<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; haskell-src-1.0.1.5<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; (haskell2010-1.0.0.0)<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; (haskell2010-1.1.0.1)<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; (haskell2010-1.1.0.1)<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; haskell98-1.1.0.1<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; (haskell98-2.0.0.1)<o:p></o:p></p><p class=MsoNormal>&nbsp;&nbsp;&nbsp; (haskell98-2.0.0.1)<o:p></o:p></p><p class=MsoNormal><o:p>&nbsp;</o:p></p><p class=MsoNormal><span style='font-size:10.0pt'>-------------------------------------------</span><o:p></o:p></p></div></body></html>