<div dir="ltr">On Wed, Nov 21, 2012 at 12:06 PM, Gregory Guthrie <span dir="ltr">&lt;<a href="mailto:guthrie@mum.edu" target="_blank">guthrie@mum.edu</a>&gt;</span> wrote:<br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div lang="EN-US" link="blue" vlink="purple"><div><p class="MsoNormal"><span style>OK; I took HTTP out, but still get the same error;<u></u><u></u></span></p><div class="im"><p class="MsoNormal"><span style>    cabal: The following packages are likely to be broken by the reinstalls:<u></u><u></u></span></p>
<p class="MsoNormal"><span style>    QuickCheck-2.4.2<u></u><u></u></span></p><p class="MsoNormal"><span style>    haskell-platform-2012.4.0.0<u></u><u></u></span></p><p class="MsoNormal"><span style>    Use --force-reinstalls if you want to install anyway.</span></p>
</div></div></div></blockquote><div><br></div><div>Right, that was not intended to be a complete fix or anything, just a note.</div><div><br></div><div>This is the important part, and what I noted immediately afterward --- did you happen to notice there was anything in the message after that first part?  (Although I&#39;m not asking this first so it also may not actually exist, I guess....)</div>
<div>  </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div lang="EN-US" link="blue" vlink="purple"><p class="MsoNormal"><span style>One thing I notice;<u></u><u></u></span></p>
<p class="MsoNormal"><span style>Ghc reports: G:\Cabal&gt;ghc --version<u></u><u></u></span></p><div class="im"><p class="MsoNormal"><span style>     The Glorious Glasgow Haskell Compilation System, version 7.4.2<u></u><u></u></span></p>
<p class="MsoNormal"><span style><u></u> <u></u></span></p></div><p class="MsoNormal"><span style>But I did notice that I had an environment variable (from some previous install, I think openCV?) of:<u></u><u></u></span></p>
<p class="MsoNormal"><span style>   GHC_VERSION=7.4.1<u></u><u></u></span></p><p class="MsoNormal"><span style>So I updated that to 7.4.2<u></u><u></u></span></p><p class="MsoNormal"><span style>And retried, same results.</span></p>
</div></blockquote><div><br></div><div>There is more going on than just that environment variable; this is what the &quot;base&quot; stuff that you have been ignoring is trying to tell you.</div><div><br></div><div>You still have both compilers installed, and their packages are somehow jumbled together.  This is breaking your installation.  Unfortunately, as I am neither particularly familiar with Windows nor able to access your system (which is probably for the best for both of us), I can&#39;t really help you with figuring out why you have two GHC versions&#39; packages mixed together.  But as long as you do, cabal will be trying to upgrade the &quot;base&quot; package, which is the actual source of the breakage.</div>
<div><br></div></div>-- <br><div dir="ltr"><div>brandon s allbery kf8nh                               sine nomine associates</div><div><a href="mailto:allbery.b@gmail.com" target="_blank">allbery.b@gmail.com</a>                                  <a href="mailto:ballbery@sinenomine.net" target="_blank">ballbery@sinenomine.net</a></div>
<div>unix/linux, openafs, kerberos, infrastructure          <a href="http://sinenomine.net" target="_blank">http://sinenomine.net</a></div></div><br>
</div>