<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:x="urn:schemas-microsoft-com:office:excel" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=utf-8"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-reply;
        color:black;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal><span style='color:black'>OK; I took HTTP out, but still get the same error;<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>    cabal: The following packages are likely to be broken by the reinstalls:<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>    QuickCheck-2.4.2<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>    haskell-platform-2012.4.0.0<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>    Use --force-reinstalls if you want to install anyway.<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'><o:p>&nbsp;</o:p></span></p><p class=MsoNormal><span style='color:black'>One thing I notice;<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>Ghc reports: G:\Cabal&gt;ghc --version<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>     The Glorious Glasgow Haskell Compilation System, version 7.4.2<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'><o:p>&nbsp;</o:p></span></p><p class=MsoNormal><span style='color:black'>But I did notice that I had an environment variable (from some previous install, I think openCV?) of:<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>   GHC_VERSION=7.4.1<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>So I updated that to 7.4.2<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>And retried, same results.<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'><o:p>&nbsp;</o:p></span></p><p class=MsoNormal><span style='color:black'>But then, ghc-pkg check reports:<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>   The following packages are broken, either because they have a problem<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>   listed above, or because they depend on a broken package.<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>   HTTP-4000.2.3<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>   haskell-platform-2012.2.0.0<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'><o:p>&nbsp;</o:p></span></p><p class=MsoNormal><span style='color:black'>I have no idea where the 2012.2 comes from.<o:p></o:p></span></p><p class=MsoNormal><span style='color:black'>Any suggestions? <o:p></o:p></span></p><p class=MsoNormal><span style='color:black'><o:p>&nbsp;</o:p></span></p><div style='border:none;border-left:solid blue 1.5pt;padding:0in 0in 0in 4.0pt'><div><div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in'><p class=MsoNormal><span style='font-size:10.0pt;font-family:"Calibri","sans-serif";color:black'>-------------------------------------------<br></span><b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>From:</span></b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'> Brandon Allbery [mailto:allbery.b@gmail.com] <br><b>Subject:</b> Re: [Haskell-cafe] cabal install... Trying to recover<o:p></o:p></span></p></div></div><p class=MsoNormal><o:p>&nbsp;</o:p></p><div><div><blockquote style='border:none;border-left:solid #CCCCCC 1.0pt;padding:0in 0in 0in 6.0pt;margin-left:4.8pt;margin-right:0in'><p class=MsoNormal>So I split it into sections, and tried the first one; it lists a lot of new installs, and then fails<br>&nbsp; (full list at <a href="http://pastebin.com/5ywdUjgX" target="_blank">http://pastebin.com/5ywdUjgX</a>)<o:p></o:p></p></blockquote><div><p class=MsoNormal><o:p>&nbsp;</o:p></p></div><div><p class=MsoNormal>You're explicitly asking it for a new version of HTTP, which is asking for trouble.<o:p></o:p></p></div><div><p class=MsoNormal><o:p>&nbsp;</o:p></p></div><div><p class=MsoNormal>More worrisome is that it's still asking for new versions of base, which means it's still confused about what version of ghc is installed.<o:p></o:p></p></div></div></div></div></div></body></html>