<div dir="ltr">The choice of fixity came about because actually the most common thing replaced by (<&>) is actually (>>=), when the thing you are binding to no longer has an effect, not actually (<$>), despite what the name suggests.<div>
<br></div><div>This made a non-trivial difference in the amount of parentheses in real code, and was a conscious decision, so reverting it is not something I would do lightly and breaks real code.</div><div><br></div><div>
Back during the discussion of whether we should adopt (&), (<&>) also came up, but with only one voice in favor, and nobody else really feeling passionately, and with various colors like this available for the bikeshed it was dropped.</div>
<div><br></div><div><div>-Edward</div><div><div><br></div></div></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Thu, Apr 17, 2014 at 3:32 PM, Hans Höglund <span dir="ltr"><<a href="mailto:hans@hanshoglund.se" target="_blank">hans@hanshoglund.se</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><div><div class=""><br><blockquote type="cite"><span style="border-collapse:separate;font-family:Helvetica;font-style:normal;font-variant:normal;font-weight:normal;letter-spacing:normal;line-height:normal;text-align:-webkit-auto;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;font-size:medium"><div dir="ltr">
Can we argue about the fixity for<span> </span><font face="courier new, monospace">(<&>)</font>? I've always it as infixl 4, to mix it in with other applicative operators, e.g.:<div><br></div><div><font face="courier new, monospace">(:) <$> fx <*> fl</font></div>
<div><br></div><div>becomes</div><div><br></div><div><font face="courier new, monospace">fx <&> (:) <*> fl</font></div></div><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<div dir="ltr"></div></blockquote></div></div></span></blockquote><div><br></div></div>I agree, this seems to be a mistake in lens.</div><div class=""><div><br><br><blockquote type="cite"><span style="border-collapse:separate;font-family:Helvetica;font-style:normal;font-variant:normal;font-weight:normal;letter-spacing:normal;line-height:normal;text-align:-webkit-auto;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;font-size:medium"><div class="gmail_extra">
<div class="gmail_quote"><blockquote class="gmail_quote" style="margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<div dir="ltr"><div class="gmail_default" style="font-family:verdana,sans-serif">Last I checked,<br><br></div><div class="gmail_default" style="font-family:verdana,sans-serif">(&) = flip ($)<br><br></div><div class="gmail_default" style="font-family:verdana,sans-serif">
is both shorter to type, and more explicit than:<br><br>import Control.Apply.Reverse<br><br></div><div class="gmail_default" style="font-family:verdana,sans-serif"> <span> </span>- Clark<br></div></div><div class="gmail_extra">
<div><br></div></div></blockquote></div></div></span></blockquote></div><br></div><div>Well the purpose here is to propose a standard name and fixity, not to save keystrokes.</div><div><br></div><div>When a lot of libraries start to define a (trivial) thing under different names, that to me is a good indication that it should be in the standard library. It is a matter of keeping the signal-to-noise ratio large, which greatly helps when reading unfamiliar code.</div>
<span class="HOEnZb"><font color="#888888"><div><br></div><div>Hans</div></font></span></div><br>_______________________________________________<br>
Haskell-Cafe mailing list<br>
<a href="mailto:Haskell-Cafe@haskell.org">Haskell-Cafe@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/haskell-cafe" target="_blank">http://www.haskell.org/mailman/listinfo/haskell-cafe</a><br>
<br></blockquote></div><br></div>