readFloat

Simon Peyton-Jones simonpj@microsoft.com
Thu, 30 May 2002 01:10:02 -0700


| It would be strange to name a function readFloat if its type is
|     RealFrac a =3D> ReadS a.
| I think the function should be named readFrac. For=20
| compatibility, one could put the following into the prelude:
|     readFloat :: RealFloat a =3D> ReadS a
|     readFloat =3D readFrac

Well, that would be possible, but there are other naming inconsistencies
in the Prelude; indeed, even in the numeric library. =20

My inclination is to put up with the inconsistency.  You have to
look up the type to use it anyhow.

Simon