Raw I/O library proposal, second (more pragmatic) draft

Ketil Z. Malde ketil@ii.uib.no
05 Aug 2003 08:50:05 +0200


"Simon Marlow" <simonmar@microsoft.com> writes:

> class Stream s where
>       closeStream	   :: s -> IO ()
>       StreamSetBuffering :: s -> BufferMode -> IO ()
        :

Just a minor suggestion, since I think some of the names get a bit
long and cumbersome.  How about:

module Stream where

class Stream s where
        close :: s -> IO ()
        setBuffering :: s -> BufferMode -> IO ()
        :

and so on.  Importing qualified gives you names like

        Stream.close, Stream.setBuffering,...

which are quite similar to your suggested ones.  I suspect a typical
use would have lots of stream operations in a few modules, so having
short (unqualified) names might be nice.

-kzm
-- 
If I haven't seen further, it is by standing in the footprints of giants