wolfgang at jeltsch.net
Mon Apr 5 16:53:48 EDT 2004
Am Montag, 5. April 2004 13:56 schrieb Sven Panne:
> I'm not sure about the module names, but simply DData as the root is not
> very nice. What about Data.DData? Something more descriptive would be even
> nicer, because the module names should describe the functionality, not the
> genesis of the modules. Using "DData" as the package name is fine.
> Suggestions welcome...
If I remember correctly, DData was intended to be the next-generation standard
set of collection modules. So, maybe, we should just name the modules
Data.Map, Data.Seq, etc. I think, it was already said that this should
probably be done. A problem is Data.Set but there may be a solution for
Since DData will not be one collection library beside others but *the*
collection library, we should avoid the name "DData" as part of a module
More information about the Libraries