simonmar at microsoft.com
Mon Mar 22 11:45:58 EST 2004
> > In an
> > ideal world, we'd rename seq which is surely up
> > there on the list of opaque,
> > immemorable function names but, in this less than
> > ideal world, using a
> > different name for Seq would be good if someone can
> > suggest one. (Sequence?)
> Robert proposes CatenableSeq, which I like because it
> reflects closely the purpose of the type.
> Unless someone has a better idea along this lines,
> I'll make the change.
I'm usually in favour of longer, more descriptive and consistent naming
schemes, but in this case I vote against the longer name, simply on the
grounds that the type is going to be quite widely used.
More information about the Libraries