State of DData
maeder at tzi.de
Thu Mar 25 18:09:29 EST 2004
JP Bernardy wrote:
> In the same vein, I've renamed MultiSet to Bag; being
> synonyms, I favoured the most usual name.
good, having looked at it, I'm missing a map (and mapMonotonic) function
for bags and maybe "subset" should be renamed to "subbag"?
> To me, this barely makes a difference whatever is
> chosen. For reasons of compatibility with the old
> FiniteMap/Set, "right bias+structure first" might be
I vote for the current state "left bias+structure last", as the bias
should not matter much and a repeated lookup can be done using the
section notation: (`Map.lookup` m)
For folding "structure last" is to be preferred as even the type of
FiniteMap.foldFM suggest! Thus e.g..insert should be like in DData.Map
and not like addToFM in Data.FiniteMap.
More information about the Libraries