Proposal: fix for getOpt (missing feature)
nominolo at googlemail.com
Mon Jun 25 19:30:09 EDT 2007
On 25 jun 2007, at 22.23, Malcolm Wallace wrote:
> Proposal: to fix a missing feature in the Haskell implementation of
> getOpt. Currently, long option names _must_ have two dashes (e.g.
> whereas this patch permits a single dash (e.g. -foo) where there is no
> short option name to be confused with it (e.g. -f).
Are, you sure this is a good idea? What if options are passed
through, or the -f option is later added? Then users have to change
there scripts, maxefiles, etc. that use these options. I don't think
this scales well.
More information about the Libraries