Proposal: Add &&& and *** to Data.Tuple
conal at conal.net
Tue Oct 16 17:10:20 EDT 2007
It wouldn't have to be a change. We could add these new synonyms. I'm
personally happy with first & second for use with functions & other Arrow
types. My main suggestion is that if we want new names for memorability,
then let's add them for the general meanings rather than the specialized
On 10/15/07, Bertram Felgenhauer <bertram.felgenhauer at googlemail.com> wrote:
> Changing the names of 'first' and 'second' in Control.Arrow is a bad
> idea, I think. It'll break a lot of packages.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Libraries