More on Proposal #2717: Add nubWith, nubOrd
ndmitchell at gmail.com
Tue Dec 2 06:28:23 EST 2008
> Could you please call it IntSet.nubOrd instead?
I considered raising this, but decided nubInt is better than nubOrd.
These functions don't really belong in Set/IntSet - its just a case of
dependencies etc. As such, I don't think the usual rules apply,
because nubOrd doesn't work on Set's at all. From a usage point of
view, nubInt/nubOrd is much clearer.
More information about the Libraries