Proposal: add new forms of unsafePerformIO
isaacdupree at charter.net
Thu Feb 14 21:59:22 EST 2008
Stefan O'Rear wrote:
> I propose that unsafeDupablePerformIO be renamed to unsafePerformIO,
> since it satisfies all of the properties guaranteed of unsafePerformIO.
> GHC's unsafePerformIO guarantees more
similar to 'let' denoting sharing normally, and not doing a computation
more than needed (most of the time). hmm.
More information about the Libraries