Help understanding a dependency conflict
aslatter at gmail.com
Fri Jan 7 22:23:48 CET 2011
On Fri, Jan 7, 2011 at 1:56 PM, tsuraan <tsuraan at gmail.com> wrote:
> I have a program that's using both json (0.4.4) and hslogger (1.1.0).
> During the "cabal configure" stage of compiling my program, I get this
> error message:
> Warning: This package indirectly depends on multiple versions of the same
> package. This is highly likely to cause a compile failure.
> package json-0.4.4 requires mtl-126.96.36.199
> package hslogger-1.1.0 requires mtl-188.8.131.52
> Looking at the .cabal files for json and hslogger, they both have
> dependencies on "mtl", but neither package gives a version for it. I
> only have mtl 184.108.40.206 installed, so installing json didn't bring in an
> old version of the library when it was installed. My program compiles
> and runs without any errors. Can anybody tell my why cabal thinks
> json needs mtl 220.127.116.11, and what I can do to make the message go away?
Is there a reason you need to make the warning go away?
Maybe your installed version of parsec is built against mtl-1 - parsec
is a dependency of json.
> Libraries mailing list
> Libraries at haskell.org
More information about the Libraries