genBits: small addition to random API + largely new implementation that needs code review
igloo at earth.li
Wed Jun 29 19:56:15 CEST 2011
On Tue, Jun 28, 2011 at 02:26:14PM -0700, Thomas DuBuisson wrote:
> Ian Lynagh <igloo at earth.li> wrote:
> > Perhaps we should fork random as old-random
> > This would probably imply the next Haskell' release not specifying
> > System.Random.
> H2010 already doesn't specify Random, unless I missed something.
Ah, better still. random98 might be a better name, in that case.
> I've never liked the "old-*" package renaming as that already
> introduces (minor) breakage and doesn't seem to encourage people to
> move forward. Why avoid using versioning and build-deps for this
> (adding a version bound is similar work to adding "old-")?
Mainly because I like to only have a single version of each package.
Just having an old version of random is another option.
More information about the Libraries