Proposal: add 'findLess' and variants to containers
wren ng thornton
wren at freegeek.org
Sat Mar 3 10:35:56 CET 2012
On 3/3/12 4:28 AM, Henning Thielemann wrote:
> On Sat, 3 Mar 2012, Milan Straka wrote:
>> I would go with
>> lookupLT, lookupLE, lookupGE, lookupGT
>> The names are short, and LT/GT are universally known from the Ordering
> +1 for same reason.
This is my preferred naming scheme too.
> I would not like the negation in "NotAbove".
I merely mentioned it because at least it's consistent/coherent, as
opposed to mixing the comparator terminology with the extrema terminology.
More information about the Libraries