Proposal: Add (&) to Data.Function
johan.tibell at gmail.com
Tue Nov 20 18:25:06 CET 2012
On Tue, Nov 20, 2012 at 9:19 AM, Dan Burton <danburton.email at gmail.com>wrote:
> I agree that Haskell should provide this idiom. I find & to be a strange
> name for it, but to be honest, it's no stranger than $ so I say go for
> it. I would suggest | to mimic the unix pipe, but this obviously clashes
> with Haskell guard syntax. I think |> is a reasonable name, but
> Data.Sequence has already claimed it.
I also like |> for the color of this shed, as there's prior art for it.
> but Data.Sequence has already claimed it.
We should use namespaces for these things instead of trying to come up with
globally unique names (be they symbols). Trying to be globally unique
doesn't scale to large codebases and eventually gives =>@@@@#$>. ;)
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Libraries