Moving basic functions

Herbert Valerio Riedel hvr at gnu.org
Wed Apr 3 12:31:06 CEST 2013


Roman Cheplyaka <roma at ro-che.info> writes:

[...]

> I'd +1 for Henning's forcePair if a better name is found (the word force
> is normally associated with being strict, although I can see why he used
> it here).

btw, just thinking out loud, what about an infix operator such as (just
as an example):

  (!.!) :: a -> b -> (a,b)
  a !.! b = a `seq` b `seq` (a,b)

which let's you write a pair as

  ( exp1 !.! exp2 )

which has a bit of a resemblance to the standard tuple-construction
syntax:

  ( exp1 , exp2 )

?

cheers,
  hvr



More information about the Libraries mailing list