Moving basic functions
roma at ro-che.info
Wed Apr 3 12:38:20 CEST 2013
* Herbert Valerio Riedel <hvr at gnu.org> [2013-04-03 12:31:06+0200]
> Roman Cheplyaka <roma at ro-che.info> writes:
> > I'd +1 for Henning's forcePair if a better name is found (the word force
> > is normally associated with being strict, although I can see why he used
> > it here).
> btw, just thinking out loud, what about an infix operator such as (just
> as an example):
> (!.!) :: a -> b -> (a,b)
> a !.! b = a `seq` b `seq` (a,b)
> which let's you write a pair as
> ( exp1 !.! exp2 )
> which has a bit of a resemblance to the standard tuple-construction
> ( exp1 , exp2 )
Did you just fall victim of forcePair's name? :)
It's about a different issue.
Or is this meant as an unrelated proposal?
More information about the Libraries