proposal/RFC: add bSwap to base in Data.Bits
tab at snarc.org
Thu May 16 11:24:59 CEST 2013
On Thu, May 16, 2013 at 11:00:11AM +0200, Thomas Schilling wrote:
> I'd strongly prefer "byteSwap". We already have shiftR, shiftL insted
> of sh[a]r, shl; I see no reason to stick to assembly convention here.
> Also "bSwap" still wouldn't make it clear that it's _byte_ swap rather
> than _bit_ swap.
well, it does if you have x86 assembly knowledge :-)
But in anycase i'm fine with byteSwap.
More information about the Libraries