It wouldn't have to be a change.  We could add these new synonyms.  I'm personally happy with first & second for use with functions & other Arrow types.  My main suggestion is that if we want new names for memorability, then let's add them for the general meanings rather than the specialized ones.
<br><br><div><span class="gmail_quote">On 10/15/07, <b class="gmail_sendername">Bertram Felgenhauer</b> &lt;<a href="mailto:bertram.felgenhauer@googlemail.com">bertram.felgenhauer@googlemail.com</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>Changing the names of &#39;first&#39; and &#39;second&#39; in Control.Arrow is a bad<br>idea, I think. It&#39;ll break a lot of packages.</blockquote><div><br>[...] <br></div><br></div><br>