I'm getting an error message with cabal's haddock command's --hyperlink-source option.   The message (below) says "haddock --hyperlink-source requires Haddock version 0.8 or later", while "haddock --version" says that I have version 
2.0.&nbsp;&nbsp; I have the latest cabal and hscolour from hackage and the latest haddock from darcs.&nbsp; I&#39;m using cygwin on WinXP.<br><br>bash-3.2$ ./setup haddock --hyperlink-source --verbose<br>Creating dist\doc\html\reactive (and its parents)
<br>Preprocessing library reactive-0.0...<br>Running hscolour for reactive-0.0...<br>Creating dist\doc\html\reactive\src (and its parents)<br>c:\Haskell\packages\bin\HsColour.exe -print-css -odist\doc\html\reactive\src\hscolour.css
<br>c:\Haskell\packages\bin\HsColour.exe -css -anchor -odist\doc\html\reactive\src\Data-IVar.html src\Data\IVar.hs<br>Creating dist\doc\html\reactive\src (and its parents)<br>c:\Haskell\packages\bin\HsColour.exe -print-css -odist\doc\html\reactive\src\hscolour.css
<br>c:\Haskell\packages\bin\HsColour.exe -css -anchor -odist\doc\html\reactive\src\Data-Fun.html src\Data\Fun.hs<br>Creating dist\doc\html\reactive\src (and its parents)<br>c:\Haskell\packages\bin\HsColour.exe -print-css -odist\doc\html\reactive\src\hscolour.css
<br>c:\Haskell\packages\bin\HsColour.exe -css -anchor -odist\doc\html\reactive\src\Data-Reactive.html src\Data\Reactive.hs<br>Creating dist\build\tmp (and its parents)<br>Creating dist\doc\html\reactive (and its parents)<br>
Preprocessing library reactive-0.0...<br>Running Haddock for reactive-0.0...<br>setup.exe: haddock --hyperlink-source requires Haddock version 0.8 or later<br>bash-3.2$ haddock --version<br>Haddock version 2.0, (c) Simon Marlow 2003; ported to the GHC-API by David Waern 2006
<br>bash-3.2$ <br><br>Ideas?&nbsp;&nbsp; - Conal<br><br>