<div class="gmail_quote">On Mon, Oct 11, 2010 at 1:12 PM, Malcolm Wallace <span dir="ltr">&lt;<a href="mailto:malcolm.wallace@me.com">malcolm.wallace@me.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
I have myself in the past implemented a Text-like library as a replacement for the standard list-of-char representation.  (Before you ask, it is not publically releasable.)  The basic decision I took there was that the Char type does not exist - the only thing available is Text.  Another way of saying this, is that Char is simply the subset of all the Texts of size 1.  I am not suggesting that the Prelude or ByteString should take this view, but if you proceed to look at the type signatures of the Data.Text package on the basis that Char/Text are the &quot;same&quot; thing, then it may become clearer how to resolve the apparent name/type clashes below.<br>
</blockquote><div><br></div><div>Thanks, Malcolm. I do like this principle, and I&#39;m comfortable with its implied further divergence from list/bytestring.</div><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div class="im"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">The breakSubstring functionality is semantically:</blockquote></div>
    breakSubstring x = break (==x)<br>
although there may be a more efficient implementation.<br>
Proposal: rename Text.break to Text.breakSubstring, and Text.breakBy to Text.break.</blockquote><div><br></div><div>So far, I&#39;ve been proceeding on the basis that I&#39;d like naming to be consistent and descriptive, and to have more commonly used functions get shorter names than their less commonly used (but possibly more general) cousins. For instance, breakSubstring is descriptive, and it&#39;s consistent with bytestring, but it&#39;s much longer than break, even though breaking on a fixed string is more common. In this case, length and frequency of use trump the other considerations in my mind.</div>
<div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im">
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
breakEnd    -         -              Text -&gt; Text -&gt; (Text, Text)<br>
-           -         breakEnd       (Char -&gt; Bool) -&gt; Text -&gt; (Text, Text)<br>
</blockquote>
<br></div>
  breakEnd    -         breakEnd       (Text -&gt; Bool) -&gt; Text -&gt; (Text, Text)<br>
<br>
Proposal: slightly generalise the type of Text.breakEnd.</blockquote><div><br></div><div>I think that these generalisations are good ideas. Can someone else please weigh in, preferably the original authors of the H-P inclusion draft (Don, Johan)?</div>
<div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
findBy      find      find           (Char -&gt; Bool) -&gt; Text -&gt; Maybe Char</blockquote></div><div class="im">
<br></div>
  find        find      find           (Text -&gt; Bool) -&gt; Text -&gt; Maybe Text<br>
<br>
Proposal: rename Text.findBy to Text.find.</blockquote><div><br></div><div>I agree with the change of type, not so much with the naming. That&#39;s roughly my stance in the other cases, too.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div class="im">I hope this is a useful contribution, if only to spark other ideas for how to resolve the impasse.</div>
</blockquote></div><br><div>Definitely, thank you.</div>