<div dir="ltr"><div><div>> What is bad about two imports?<br><br>It is a breaking change from the current Data.Tree API. <br><br></div>From Milan' proposal:<br>> users would write<br>>  import qualified Data.Tree as Tree<br>>  import qualified Data.Tree.Forest as Forest<br>>and then use the methods as<br>>  Tree.lookupTree<br>>  Tree.filter<br>>and<br>>  Forest.filter<br><br></div><div>Which, I would guess, would imply turning:<br></div><div>Data.Tree.unfoldTree  -> Data.Tree.unfold<br></div><div>Data.Tree.unfoldForest -> Data.Tree.Forest.unfold<br></div><div>
<br></div><div>Thus breaking existing code.<br><br></div><div>But again, I don't have a strong opinion about this. What really matters is to have the new functions (and comonad references) in the API.<br><br></div><div>Cheers,<br></div><div>João<br></div></div><div class="gmail_extra"><br><div class="gmail_quote">2015-01-01 10:20 GMT+00:00 Henning Thielemann <span dir="ltr"><<a href="mailto:lemming@henning-thielemann.de" target="_blank">lemming@henning-thielemann.de</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><br>
On Wed, 31 Dec 2014, João Cristóvão wrote:<br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
For the record, nevertheless, I was moving along with the separate Tree/Forest modules to avoid further bikeshedding, but to be honest I don't really see a big advantage - if your using one, you most probably will also need to use the other, so why two imports?<br>
</blockquote>
<br></span>
What is bad about two imports?</blockquote></div><br></div>