<div dir="ltr">Of course, there&#39;s always the easy way: spawn-fcgi[1]. I just stumbled upon it, this seems like the &quot;right way.&quot;<div><br></div><div>Using this, I think I&#39;ll try to add a nginx section to the deploying page[2], and maybe even get some benchmarks between lighttpd and nginx. Seems like Cherokee could also fit the bill here.<br>
<div><br></div><div>[1] <a href="http://redmine.lighttpd.net/projects/spawn-fcgi">http://redmine.lighttpd.net/projects/spawn-fcgi</a></div><div><a href="http://redmine.lighttpd.net/projects/spawn-fcgi"></a>[2] <a href="http://docs.yesodweb.com/yesod/deploying.html">http://docs.yesodweb.com/yesod/deploying.html</a><br>
<br><div class="gmail_quote">On Mon, Jul 26, 2010 at 4:52 PM, Michael Snoyman <span dir="ltr">&lt;<a href="mailto:michael@snoyman.com">michael@snoyman.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div dir="ltr">OK, I had to do a little research into this one: I&#39;ve never used nginx, only lighttpd and Apache. Both of those automatically spawn the FastCGI process.<div><br></div><div>Basically, the FastCGI spec requires file descriptor 0 to be a socket for receiving the incoming connections. When lighttpd or Apache spawn a FastCGI process, they handle all of the &quot;fun parts&quot; themselves. With nginx, we&#39;ll have to do it ourselves.</div>

<div><br></div><div>I&#39;ve attached a C file called &quot;runner.c&quot; which creates a socket, binds it to a port, calls dup2 to replace stdin with this new socket and then execs a new application (called &quot;bind&quot; here). You should be able to replace &quot;1100&quot; with your desired port number and &quot;bind&quot; with your application name and it will run your FastCGI script appropriately.</div>

<div><br></div><div>Obviously, this is a suboptimal solution; it would be nice if the FastCGI handler did all of this stuff for us. I&#39;ll toy around with that and see if I can get anything working. Please let me know if this solution works; if so, could you send me you nginx config file? I&#39;ve been wanting to try it out as a replacement for lighttpd.</div>

<div><br></div><font color="#888888"><div>Michael</div></font><div><div></div><div class="h5"><div><br><div class="gmail_quote">On Mon, Jul 26, 2010 at 3:44 PM, Mark Bradley <span dir="ltr">&lt;<a href="mailto:barkmadley@gmail.com" target="_blank">barkmadley@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
okay so my config is a little off (don&#39;t need the http://).  But<br>
non-the-less I cannot seem to find a way to start a yesod app as a<br>
fastcgi process (I don&#39;t really have and experience with fastcgi).<br>
<br>
Apparently apache and lighttpd start fastcgi processes for you so they<br>
don&#39;t have my problem, but I at least want to give nginx a go.<br>
<font color="#888888"><br>
Mark<br>
</font><div><div></div><div><br>
On Mon, Jul 26, 2010 at 7:36 PM, Mark Bradley &lt;<a href="mailto:barkmadley@gmail.com" target="_blank">barkmadley@gmail.com</a>&gt; wrote:<br>
&gt; I&#39;ve spent a bit of time trying to setup a yesod app under nginx using<br>
&gt; fastcgi.  The server config looks a little like this (statics get<br>
&gt; served by nginx which is nice)<br>
&gt;<br>
&gt; server {<br>
&gt;        listen       80;<br>
&gt;        server_name  <a href="http://domain.com" target="_blank">domain.com</a>;<br>
&gt;<br>
&gt;        access_log  #<br>
&gt;        error_log   #<br>
&gt;<br>
&gt;        location ~ ^/s/.* {<br>
&gt;            root /path/to/static/static;<br>
&gt;        }<br>
&gt;<br>
&gt;        location ~ ^/ {<br>
&gt;            include /etc/nginx/fastcgi_params;<br>
&gt;            fastcgi_pass <a href="http://127.0.0.1:3000" target="_blank">http://127.0.0.1:3000</a>;<br>
&gt;        }<br>
&gt; }<br>
&gt;<br>
&gt; unfortunately I couldn&#39;t get the wai-handler-fastcgi package to run properly.<br>
&gt;<br>
&gt; Server: user error (FCGX_Accept failed with error code: -88)<br>
&gt;<br>
&gt; I couldn&#39;t find error code -88 easily and I am guessing that I need to<br>
&gt; set a particular port for the app to run on, unfortunately I didn&#39;t<br>
&gt; see any way to do this through the wai api? (it does appear the<br>
&gt; wai-handler-snap&#39;s run function takes an Int...)<br>
&gt;<br>
&gt; I&#39;m just a little confused at the moment.<br>
&gt;<br>
&gt; Regards,<br>
&gt; Mark<br>
&gt;<br>
_______________________________________________<br>
web-devel mailing list<br>
<a href="mailto:web-devel@haskell.org" target="_blank">web-devel@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/web-devel" target="_blank">http://www.haskell.org/mailman/listinfo/web-devel</a><br>
</div></div></blockquote></div><br></div></div></div></div>
</blockquote></div><br></div></div></div>